Úvodní obrázek

priesnitz.cz

Základní funkce MS Excelu

Tabulkový procesor MS Excel dává k dispozici široké spektrum funkcí. V tomto přehledu se podíváme na základní z nich a popíšeme si stručně jejich použití.
Znalost těchto funkcí je mimo jiné klíčová pro zájemce o získání certifikátu ECDL.

Funkce a jejich argumenty

Všechny funkce, používané přímo v prostředí programu MS Excel, mají jednoznačně daný způsob zapisování. Tato tzv. syntaxe je podle předpisu FUNKCE(argumenty), přičemž funkce je většinou jakási početní operace a slovem argument označujeme data (většinou čísla), se kterými je operace prováděna.

Argumentů může být libovolné množství. Jejich počet a hodnoty jsou většinou dány tím, co po nás bude funkce požadovat pro svoje správné provedení. Existují funkce bez argumentu (například funkce DNES()), ale i funkce, které mají tři a více argumentů.

Jenodtlivé argumenty můžeme zapsat buďto jako čísla anebo, častěji, jako odkazy na konkrétní buňky. Při jejich zadávání jednotlivé hodnoty oddělujeme znamínkem ; (středník).

Funkce se také dají zanořovat do sebe, čímž můžeme dosáhnout složitějších výpočtů. Příkladem může být formule ZAOKROUHLIT(ODMOCNINA(A1);0), která nejprve spočítá odmocninu z čísla v buňce A1 a tento výsledek pak matematicky zaokrouhlí na celá čísla.

Chceme-li do buňky zapsat funkci, musíme ji, stejně jako u jiných vzorců, uvodit znaménkem =.

Základní funkce

Nyní si ukážeme několik základních funkcí, které jsou pro práci v Excelu stěžejní.

Součet SUMA(oblast)

Funce suma nám provede součet všech číslených buněk v zadané oblasti. Buňky s nečíselným formátem nebudou do součtu zahrnuty.

=SUMA(A1;B3;C5:D7) nám provede součet všech číselných hodnot v buňkách A1, B3 a v oblasti od C5 do D7

PRŮMĚR(oblast)

Funkce průměr provede aritmetický průměr všech číselných dat v zadané oblasti. Pokud bude v zadané oblasti prázdná buňka nebo buňka s nečíselným formátem, bude se ignorovat. Buňka s hodnotou 0 (nula) je brána jako číselná hodnota 0.

=PRŮMĚR(E10:E14) vypočítá aritmetický průměr ze všech čísel v oblasti od E10 do E14

Minimum MIN(oblast) a maximum MAX(oblast)

Tyto dvě funkce používáme v případě, že chceme z určitého souboru číselných hodnot vybrat tu nejmenší, nebo naopak největší.

=MIN(A1:C10) zjistí, jaká je nejmenší číselná hodnota v zadané oblasti
=MAX(A1:C10) zjistí, jaká je největší číselná hodnota v zadané oblasti

Počet čísel v oblasti POČET(oblast)

Funkce počet vrátí (zjistí), kolik je v zadané oblasti číselných hodnot, uložených v číselném formátu (ignorují se tak čísla, která jsou v buňkách uložená jako text). Ignorují se také prázdné buňky.

=POČET(A1:F10) zjistí, kolik je v oblasti A1:F10 buněk, obsahujících číselné hodnoty

Počet neprázdných buněk v oblasti POČET2(oblast)

Funkce počet2 se od předchozí funkce počet liší v tom, že nám vrátí počet všech obsazených buněk. Je tedy jedno, jestli v buňce máme číslo nebo textový řetězec - jakmile je obsazená, započítá se do výsledku.

=POČET2(A1:F10) zjistí, kolik buněk je v oblasti A1:F10 obsazených libivolnou hodnotou


Rozdíl mezi funkcemi POČET a POČET2

Logické funkce

Logické funkce se používají pro rozhodování. Základní "početní" soustavou jsou dvě hodnoty - ANO a NE, které jsou často reprezentovány čísly 1 a 0. V praxi se většinou hodnoty těchto funkcí posuzují tak, že máme-li v buňce hodnotu 0 (nebo je buňka prázdná), značí to honodtu NE (nepravda) a je-li v buňce jakýkoliv obsah, znamená to ANO (pravda).

Hodnoty ANO a NE se používají proto, že logické funkce jsou většinou používány k vyhodnocování nějakých podmínek.

Máme firemní akci, kdy zákazníci kteří nakoupí na fakturu nad 10 000Kč, dostanou zdarma firemní hrníček. Chceme-li tuto operaci zautomatizovat tak, aby ji hlídal sám program (v našem případě Excel), bude logické začít analýzu této situace dotazem: "Nakoupil zákazník XXY nad 10 000Kč?" Odpovědí pak může být právě ono logické "ANO" a nebo "NE". Na základě takovéhoto vyhodnocení situace můžeme dále postupovat - například se na fakturu automaticky připíše položka "Hrnek zdarma".

Rozhodovací funkce KDYŽ(podmínka;[ano];[ne])

Když je základní rozhodovací funkce v Excelu. Používá se právě v případech, kdy chceme rozhodnout nějakou situaci. Navíc můžeme také nadefinovat, jak se bude funkce chovat v případě vyhodnocení podmínky jako pravdivé a nepravdivé. Všechny tyto vstupy a výstupy se zadávají do pole argumentů.

podmínka je matematicky zapsaný výraz, který budeme chtít vyhodnocovat
[ano] je argument, do kterého zapíšeme, co se stane pokud bude výsledek podmínky vyhodnocený jako pravdivý
[ne] je opakem ano, tedy co se stane pokud bude prodmínka vyhodnocená jako nepravdivá

Zkusíme si vyhodnotit informaci o tom, jestli je hodnota v buňce A1 kladná nebo záporná. Použijeme tyto argumenty:
- jako podmínku zadáme A1>0,
- jako hodnotu [ano] dáme "kladné" (včetně uvozovek, protože se jedná o textový řetězec)
- jako hodnotu [ne] dáme "záporné" (včetně uvozovek, protože se jedná o textový řetězec)

Výsledná funkce bude tedy zapsána jako =KDYŽ(A1>0;"kladné";"záporné").
Na následujícím obrázku vidíte výsledky takovéto funkce, kde se vyhodnocuje hodnota ve sloupci A a výsledek této oprerace najdeme ve sloupci B:


Můžete si všimnout, že když je v políčku nula a nebo je prázdné, je to vyhodnoceno jako záporná hodnota. Pokud se podíváme, jak jsme formulovali podmínky naší funkce, zjistíme, že chyba není na straně Excelu, ale našeho zadání. Pokud bychom chtěli funkce vnořovat, mohli bychom dále vzorec upravit například takto:
=KDYŽ(A1>0;"kladné";KDYŽ(A1=0;"nula";"záporné"))

Výsledek by pak vypadal následovně:

Pokud mi chcete napsat k tomuto článku, klikněte zde.